Partial Email Delivery Impact

Incident Report for Robly

Resolved

All systems are now operating normally, and services have been fully restored.

Thank you for your patience and understanding while this issue was being addressed.
Posted Oct 20, 2025 - 18:28 EDT

Update

Our third-party vendor has confirmed that the outage has been fully resolved. All systems are now operating normally, and services have been fully restored. We’ll continue to monitor performance to ensure stability.
Posted Oct 20, 2025 - 18:04 EDT

Monitoring

Our third-party vendor has implemented a mitigation and is currently in the process of recovery.

We continue to closely monitor the situation to ensure full restoration of service. Some customers may still experience intermittent delays or errors while sending campaigns or accessing related features.

We’ll share another update once the recovery is complete or as soon as more information becomes available.
Posted Oct 20, 2025 - 09:20 EDT

Identified

We are still seeing issues with one of our third-party vendors and continue to monitor the recovery process.

Email delivery may be partially affected, and some customers could experience delays or errors when sending campaigns or viewing stats.

We’ll provide another update within the next hour or as soon as more information becomes available.
Posted Oct 20, 2025 - 08:22 EDT
This incident affected: Email Delivery.