Delays in the Sending Process
Incident Report for Robly
Resolved
This incident has been resolved.
Posted Mar 16, 2022 - 18:54 PDT
Identified
Robly is aware of intermittent delays in the sending process affecting some customers. Our team has already identified the root cause. We will follow up promptly with another update as information becomes available.
Posted Mar 16, 2022 - 16:30 PDT
This incident affected: Email Delivery.