Website Latency
Incident Report for Robly
Resolved
This incident has been resolved.
Posted May 18, 2018 - 10:36 PDT
Identified
We've identified the issue and the system is returning to normal functionality.
Posted May 18, 2018 - 09:53 PDT
Investigating
We are currently investigating this issue. We are seeing system wide latency and timeout errors. This impacts campaign sending, test emails, imports/exports, and system navigation.
Posted May 18, 2018 - 06:24 PDT
This incident affected: Web Portal, Email Delivery, and API.